Bluetooth controller stops working after idle

Home Forums RetroPie Project Controller Configuration in RetroPie Bluetooth controller stops working after idle

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of rion rion 1 year ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #121123
    Profile photo of oakis
    oakis
    Participant

    RetroPie 3.6
    Raspberry Pi 3
    Original power supply 2.5a
    updated/upgraded via apt-get 18/3 (updating atm)
    bluetooth-pi is newest version
    original PS3 controller

    Everything works great, until i go grab dinner or something that takes about the same amount of time. Now my controller is no longer working. Turning it off and then turning it on again does not help, it wont connect. It wont connect with usb cable plugged in either.

    I havn’t tested any other game than Ocarina of Time on N64 (since it is awesome!)

    The only solution I’ve come up with is sudo reboot and that sucks.

    Anyone know what I can do to fix this?

    • This topic was modified 1 year ago by Profile photo of oakis oakis.

    #121603
    Profile photo of oakis
    oakis
    Participant

    Am I the only one with this problem? 🙁

    #121607
    Profile photo of rion
    rion
    Participant

    Have you tried this

    https://github.com/retropie/retropie-setup/wiki/Setting-up-a-Bluetooth-controller

    Keep bluetooth scanning
    This should keep the Pi scanning for bluetooth devices in case the pair is lost.
    sudo nano /etc/init.d/rc.local
    add “sudo hciconfig hci0 up piscan” (without the quotes) above the line that says “exit 0”
    ctrl x
    y
    enter
    sudo reboot

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar