Source-Based Installation Crashes Every Time

Home Forums RetroPie Project Everything else related to the RetroPie Project Source-Based Installation Crashes Every Time

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of petrockblog petrockblog 2 years, 9 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #19205
    Profile photo of deaftolight
    deaftolight
    Participant

    So last night I did a clean install of wheezy (from the wheezy image, not the retropie setup image), updated repositories and upgraded packages, and downloaded retropie setup from the command line. I updated retropie_setup just in case, restarted retropie setup, and then chose source-based installation. This morning, I don’t see anything outputted to the screen. I tried hitting the keyboard a couple of times to wake the screen back up, but nothing happened. I scanned the network and the raspberry pi does not have an IP anymore. Unplugging and replugging the HDMI, keyboard, network cable doesn’t do anything. The only thing I was able to do was unplug the Raspberry Pi and plug it back in. Unfortuantely, when I do this, I can see not everything was installed, and the .tar.gz log file that is in /home/pi/RetroPie-Setup/logs is empty and 0 bytes.

    #19674
    Profile photo of deaftolight
    deaftolight
    Participant

    It happened again.

    I tried to start from scratch again, compiling everything from source, and when I came back this morning, it was back to a black screen. I can’t do anything, and it’s not connected to the network anymore so I can’t SSH in either. The only thing I can do is unplug and replug the raspberry pi. Unfortunately, the log file in /home/pi/RetroPie-Setup/logs is 0 bytes. This hapened yesterday as well. Can anyone tell me why it is freezig when trying to compile everything from source?

    #19945
    Profile photo of petrockblog
    petrockblog
    Keymaster

    This might come from insufficient amount of RAM when compiling the N64 emulator mupen64. Unfortunately, this is not checked before compiling mupen64 in the RetroPie-Setup Script. I have added this issue to the issue tracking list of the RetroPie-Setup Script.
    You might try to set the GPU memory to 16 MB via sudo raspi-config before running the complete source-based installation. Remember to set back this setting to 256 MB before running EmulationStation!

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar