B+ showing 256mb memory

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 3 replies, has 2 voices, and was last updated by Profile photo of buzz buzz 2 years, 3 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #84247
    Profile photo of rickandersen
    rickandersen
    Participant

    Hi

    I am new to this project. I am setting up a unit and am only seeing 256mb of memory when running the “free -m” command. I have another sd card with NOOBS on it. When I put that card in the unit and run the command it shows the full 512mb. I’ve run the “sudo apt-get update” “sudo apt-get upgrade” and “sudo rpi-update” commands with no luck. Does anyone know what else I need to do for this to recognize the full 512mb of memory in the unit?

    #84248
    Profile photo of buzz
    buzz
    Keymaster

    this is because the other 256MB is allocated for the GPU. noobs may be set to allocate much less. emulation station needs plenty of memory for the gpu. you can tweak the amount by editing /boot/config.txt (Look for gpu_mem_512 setting)

    #84249
    Profile photo of rickandersen
    rickandersen
    Participant

    Hmm. OK. I see that setting and it is set to 256. I was going off of what was showing under the “memory split” section of the raspi-config tool which shows the gpu as having 128. Do you recommend sticking with 256?

    #84257
    Profile photo of buzz
    buzz
    Keymaster

    If you are running low on ram, you could decrease it a bit. depends what resolution you are running in etc.

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar