Atari 9-pin Controllers won't go UP or LEFT – fix enclosed for compiling :)

Home Forums RetroPie Project Everything else related to the RetroPie Project Atari 9-pin Controllers won't go UP or LEFT – fix enclosed for compiling :)

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 3 replies, has 3 voices, and was last updated by Profile photo of ervine ervine 1 year, 6 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #6757
    Profile photo of IIeBoy
    IIeBoy
    Participant

    Firstly, and again, thank you to the developer for making RetroPie exist. I have had a really nostalgic and fun time with my project “Apple Piie” (see my other thread) and almost everything is working now as it should, with a few exceptions.

    As you may know, there is an issue with all the popular Atari 9-pin joystick > USB adapters, such as those on Amazon. Basically UP and LEFT on the joystick are not recognized during the Input config process.

    This affects a lot of people and so has been solved at a href=”http://www.raspberrypi.org/forums/viewtopic.php?f=78&t=36564&hilit=atari+joystick+left+up&start=25

    Could you kindly compile the fix into the next update?

    Thanks!

    IIeBoy

    #21894

    Necromancyr

    Aside from the spam post above, wanted to bump the OP since if this could be built into RetroPie I think it would be a HUGE help in getting everything working easily.

    #93764
    Profile photo of ervine
    ervine
    Participant

    Same here, I am using the Innex USB converter to connect two Suzo Arcade joysticks. I have tested this with 2.3 and 3.0b1. Same symptoms, and can be solved like this:

    https://github.com/robmcmullen/hid-atari-retrobit/blob/master/README.rst

    Can you consider using this in the retropie distro?

    #107690
    Profile photo of ervine
    ervine
    Participant

    Tested with 3.1 and issue still exists. This makes Retropie useless to me as a replacement for PC-based Amiga and C64 emulators.

    Could you please compile this fix in a next update?

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar