ATARI 2600 player 2 not recognized

Home Forums RetroPie Project Controller Configuration in RetroPie ATARI 2600 player 2 not recognized

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of odkmo odkmo 1 year, 8 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #101878
    Profile photo of odkmo
    odkmo
    Participant

    I have a Raspberry Pi 2 with version 3.0 beta 4 installed successfully with 2 Logitech F310 controllers and a MAME joystick. All controllers work fine and are recognized in NES, SNES, Megadrive, MAME, etc. The problem I am having is that only 1 controller (for player 1) is recognized in the Atari 2600 emulator. I am not able to play any 2 player games. I have checked the controller configuration file for Atari 2600 and it directs it to the “all” controller configuration file. I was wondering if there is something that needs to be added to the Atari 2600 controller configuration file to allow it to recognize a second controller for 2 players. Thanks in advance to anyone who can help!

    #102807
    Profile photo of diedaily
    diedaily
    Participant

    I’m having this same exact issue but I’m on a Raspberry Pi 2 with version 3.0 RC1. Player 2 works in the other emulators I’ve tried, such as NES, SNES, and Genesis. I’m very new to RetroPie, so I’ve hit the end of my limited knowledge. I’ve watched several of Floob’s Youtube videos on controller configuration, have followed the steps and checked configuration files, and everything seems in order yet player 2 doesn’t work in Atari 2600.

    Anyone have any ideas?

    #104348
    Profile photo of odkmo
    odkmo
    Participant

    So I went over to GitHub and posted the question about player 2 with Atari 2600 not working. The problem seems to be with the code in the image that is downloaded and not a configuration issue. The files in the Git Hub repository have been amended to fix this issue. The solution is to go to RetroPie-Setup in the RetroPie menu and then install the emulator from source. You need to use the space bar to toggle off all the options that aren’t related to Atari2600 (otherwise it would take quite some time to install them all from source). I installed Stella, Retroarch, and lr-stella. I now have 2 player control with all the games I have tested so far. Hope this helps.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar