Analog sticks with some emulators

Home Forums RetroPie Project Everything else related to the RetroPie Project Analog sticks with some emulators

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 18 replies, has 4 voices, and was last updated by Profile photo of andlinux andlinux 2 years, 1 month ago.

Viewing 19 posts - 1 through 19 (of 19 total)
  • Author
    Posts
  • #89106
    Profile photo of andlinux
    andlinux
    Participant

    Hi,

    I’m experimenting a few weeks now with Retropie and I’m using a few systems on Retropie like NES, SNES, Megadrive, FBA, Atari2600 and PSX.

    I’m also using a USB gamepad with analog sticks, It’s a Trust GXT30. Controller Photo

    My controller is working very good in systems like the NES, SNES, Megadrive, etc. It’s also configured to exit an emulator with the hotbutton (select) and the start button.
    But I also want to use my analog sticks like in the PSX emulator and also in FBA.

    But where can I setup my controls for the PSX system and if possible for the FBA system ?

    #89113
    Profile photo of killer101
    killer101
    Participant

    Try adding this to whatever config file you are using …

    input_up_axis = “-1”
    input_down_axis = “+1”
    input_left_axis = “-0”
    input_right_axis = “+0”

    input_analog_dpad_mode = “1”

    #89132
    Profile photo of andlinux
    andlinux
    Participant

    I added it to /opt/retropie/configs/all/retroarch.cfg
    and started first a PSX game. The analog sticks didn’t work.
    Maybe it would work with an NES game just to test it but even that didn’t work.

    I’ve also checked out the /opt/retropie/configs/psx/ directory but I see a retroarch.cfg file in there. So changing this will override the global one.

    Even though it’s strange when I did ./retroarch-joyconfig to configure my controller, the analog sticks worked.

    • This reply was modified 2 years, 1 month ago by Profile photo of andlinux andlinux.
    #89144
    Profile photo of killer101
    killer101
    Participant

    If retroarch autodetects your controller the config files are in here …

    /opt/retropie/emulators/retroarch/configs/

    #89278
    Profile photo of andlinux
    andlinux
    Participant

    I see the config files but are you sure that there is one that my system is using for my controller ?

    Attachments:
    #89315
    Profile photo of killer101
    killer101
    Participant

    Can’t say that, this is for you to decide. One indication is the OSD in Retroarch when starting a game. Mine displays a short message that it autodetects the PS3 Controller and which file it is using!

    #89338
    Profile photo of justinbeaird
    justinbeaird
    Participant

    You figure this out? I have been trieng to get the analog sticks working in psx for a week now with Xbox 360 remote and no one will help I have seen a lot of others asking also.

    #89341
    Profile photo of andlinux
    andlinux
    Participant

    Still figuring it out, I think I’m gonna try some more in the weekend.

    #89342
    Profile photo of killer101
    killer101
    Participant

    Can’t say anything about the XBOX Controller. But just simply test it. I’m pretty sure there is a autoconfig file for 360 Controller. Just insert the lines mentioned above and see for yourself.

    #89344
    Profile photo of labelwhore
    labelwhore
    Participant

    You figure this out? I have been trieng to get the analog sticks working in psx for a week now with Xbox 360 remote and no one will help I have seen a lot of others asking also.

    I find this surprising. PSX worked pretty much out of the box for me, including analog sticks. What method are you using to initialize the xboxdrv?

    After I installed xboxdrv, edited rc.local, rebooted, then chose “register retroarch controller” via the setup script, psx basically just worked.

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

    #89346
    Profile photo of labelwhore
    labelwhore
    Participant

    I see the config files but are you sure that there is one that my system is using for my controller ?

    if you’re using an xbox360 controller, it’s the last one.

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

    #89348
    Profile photo of killer101
    killer101
    Participant

    If your controller isn’t autodetected and you have made your settings directly in the retroarch.cfg, look for a parameter called something like autodetection and set it to false. Add the lines mentioned above to the retroarch.cfg and see what happens. Maybe it will work.

    #89454
    Profile photo of andlinux
    andlinux
    Participant

    Well I had some time to experiment and now my left analog stick is working.

    It’s thanks to killer101 but I changed something.

    input_player1_up_axis = “-1”
    input_player1_down_axis = “+1”
    input_player1_left_axis = “-0”
    input_player1_right_axis = “+0”
    input_analog_dpad_mode = “1”

    The player1 did it.
    I saw this because the rest of the config was like that.

    This is the input config at the moment (/opt/retropie/configs/allretroarch.cfg)

    input_enable_hotkey_btn = “8”
    input_exit_emulator_btn = “9”
    input_save_state_btn = “5”
    input_load_state_btn = “4”
    input_volume_up_axis = “-1”
    input_volume_down_axis = “+1”
    input_menu_toggle_btn = 3

    input_player1_joypad_index = “0”
    input_player1_b_btn = “2”
    input_player1_y_btn = “3”
    input_player1_select_btn = “8”
    input_player1_start_btn = “9”
    input_player1_up_btn = “h0up”
    input_player1_down_btn = “h0down”
    input_player1_left_btn = “h0left”
    input_player1_right_btn = “h0right”
    input_player1_a_btn = “1”
    input_player1_x_btn = “0”
    input_player1_l_btn = “4”
    input_player1_r_btn = “5”
    input_player1_l2_btn = “6”
    input_player1_r2_btn = “7”
    input_player1_l3_btn = “10”
    input_player1_r3_btn = “11”
    input_player1_l_x_plus_axis = “+0”
    input_player1_l_x_minus_axis = “-0”
    input_player1_l_y_plus_axis = “+1”
    input_player1_l_y_minus_axis = “-1”
    input_player1_r_x_plus_axis = “+2”
    input_player1_r_x_minus_axis = “-2”
    input_player1_r_y_plus_axis = “+3”
    input_player1_r_y_minus_axis = “-3”

    input_player1_up_axis = “-1”
    input_player1_down_axis = “+1”
    input_player1_left_axis = “-0”
    input_player1_right_axis = “+0”

    input_analog_dpad_mode = “1”

    #89532
    Profile photo of killer101
    killer101
    Participant

    Yes for sure. The not player1 version only works in the auto config files as there are no players defined.

    #89637
    Profile photo of justinbeaird
    justinbeaird
    Participant

    found a out how to fix it on psx all is working including rumble pack on xbox 360 controller, I got pissed so I reinstalled plugged in controller changed one thing in

    /opt/retropie/configs/all/retroarch-core-options.cfg

    changed
    pcsx_rearmed_pad1type = “standerd”
    to
    pcsx_rearmed_pad1type = “analog”

    thats all i did on fresh install 🙂

    this line wont be there until you launch psx, this and a few other psx lines are auto added after first psx launch

    killer101 lines just created a fake analog stick that copied and behaved like the dpad

    Ape escape is a good game to test analog sticks.

    Wild 9 is good to test rumble/ haptic feedback

    #89647
    Profile photo of killer101
    killer101
    Participant

    And that was exactly the intention. Not for PSX for me, but I wanted to play all the other emus with the analog stick instead of the dpad.

    #89649
    Profile photo of justinbeaird
    justinbeaird
    Participant

    And that was exactly the intention. Not for PSX for me, but I wanted to play all the other emus with the analog stick instead of the dpad.

    My controller is working very good in systems like the NES, SNES, Megadrive, etc. It’s also configured to exit an emulator with the hotbutton (select) and the start button.
    But I also want to use my analog sticks like in the PSX emulator and also in FBA.

    But where can I setup my controls for the PSX system and if possible for the FBA system ?

    fba controller configs are in /opt/retropie/emulators/pifba/fba2x.cfg

    • This reply was modified 2 years, 1 month ago by Profile photo of justinbeaird justinbeaird.
    #89652
    Profile photo of killer101
    killer101
    Participant

    Only if you stick with piFBA. Anyone doing this? The libretro core now runs full speed and gets along with a lot more games than piFBA.

    #89692
    Profile photo of andlinux
    andlinux
    Participant

    Just tried psx and it’s working with the game Ape Escape.
    Although that line pcsx_rearmed_pad1type = “standerd” wasn’t standing in that file so I added it myself and with “analog” instead of “standard”.

Viewing 19 posts - 1 through 19 (of 19 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar