Alternate rom path on usb drive

Home Forums RetroPie Project Everything else related to the RetroPie Project Alternate rom path on usb drive

RetroPie has a new website and forum. Please visit for the new site. The new forum is located at This forum is left here as a read-only archive.

This topic contains 6 replies, has 5 voices, and was last updated by Profile photo of taksoto taksoto 1 year, 11 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #92472
    Profile photo of ratsflif

    How can I set an alternate rom path for certain emulators? For example I would rather run psx\sega cd\pce cd games from a thumb drive because they take up so much more room than the cartridge systems and my 32gb sd card is nearly full.


    • This topic was modified 2 years, 1 month ago by Profile photo of ratsflif ratsflif.

    Profile photo of taalas

    You can either edit the appropriate rom path in /etc/emulationstation/es_systems.cfg or create a symbolic link for the folder you would like to have somewhere else in /home/pi/RetroPie/roms…

    There are more ways but those seem simplest to me for what you would like to do…

    Profile photo of dpicc68

    I have a USB running all of my Roms.

    It took a while to workout the correct way… i.e. permissions, samba share, gamelists stored on USB using scraper etc..

    Here is how I got it up and running:-

    First Format and Mount (with exec) USB to ext4…
    Note that you have to mount it with exec permissions otherwise you cannot run the scraper script…
    I used the following:-

    Insert empty USB – mine automatically copied across the folders from SD Card….you may need to run retropie setup script…. copy usb roms etc.

    to format USB-

    to mount with exec USB-

    To setup rom paths-

    note that when you follow the tutorial… you may not want to point the samba share to USB roms….
    You may need to search how to have 2 samba shares on the pi…

    Once your done… ssh in and navigate to the USB directory and check out what permissions you have..

    to list permissions / files/folders:-
    #ls -l

    you should then set the entire USB to “pi permissions”
    #sudo chown -R pi:pi /media/usb
    Make sure that the path is correct…

    list the permissions/files/folders again and make sure pi is set.

    Hope this helps……GoodLuck

    Profile photo of gamerx

    I am looking to try this as well. I will try dpicc instructions and report my findings. I plan on using a 128gb usb stick for my roms.

    Profile photo of taksoto

    I have a Pi 2 running retropie 2.6. I have limited space on my sd card so I was attempting to put everything on a separate USB drive. As I put the roms onto my usb drive, I tried to copy the folder tree on the pi so changing es_systems.cfg would be easy.
    Once I inserted the USB and went to change the config file, it instead copied 1/3 of the files from the USB to the sd card. Any idea how to disable that feature?

    Profile photo of dpicc68

    I used a clean USB…. as it needs to be formated correctly.
    This is a good guide..

    Profile photo of taksoto

    Since I plan on doing more than just retropie on it at once, once you reboot it, it copies everything from the USB to the sd, that method still doesn’t work. So far no way to turn off the autocopy USB. So I’m just going to setup a symbolic link.

    Also, in /etc/emulationstation/es_systems.cfg, I’m noticing that all/most of the systems are duplicated. Any idea why?

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at

Skip to toolbar