ALSA lib pcm.c:7339:(snd_pcm_recover) underrun occurred

Home Forums RetroPie Project Everything else related to the RetroPie Project ALSA lib pcm.c:7339:(snd_pcm_recover) underrun occurred

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 6 replies, has 4 voices, and was last updated by Profile photo of labelwhore labelwhore 1 year, 11 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #97026
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    is anyone else having this issue? is it serious? is there a fix?

    i’m running;
    h/w: raspberry pi 2 running from flash drive
    s/w: latest version

    edit:
    think I’ll try this later

    audio_out_rate=44100
    audio_driver=sdl

    #97028
    Profile photo of kitchuk
    kitchuk
    Participant

    I noticed this error as of recent. Anyone know what causes this?

    #97038
    Profile photo of sevik
    sevik
    Participant

    I had this problem when running mupen64plus. In addition the sound was extremly loud. I fixed it by changing the audio plugin in “/opt/retropie/configs/n64/mupen64plus.cfg”.

    # AudioPlugin = mupen64plus-audio-omx
    AudioPlugin = “mupen64plus-audio-sdl”

    Note: I’m not an expert and I don’t really understand what I’ve done. But so far it works 😉

    #97105
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    ok, so this IS a known issue!

    http://mailman.alsa-project.org/pipermail/alsa-devel/2013-January/058136.html

    i think i’s just a search now of a work around. thats for all systems, as this happens to me with psx, neo geo, sega cd and pce. not sure if any others are effected, i’ll hopefully get to check this out over the next few days.

    but any suggestions, or help would be wonderful,

    thank you sevik

    #97108
    Profile photo of labelwhore
    labelwhore
    Participant

    I can speak to this on a high level. I’m somewhat of a digital audio expert. However, I’m a linux noob.

    The problem is, as the error states with the memory buffer for processing audio. Information isn’t being processed from that buffer fast enough to add anything else to it. Theoretically, there are two ways to fix it; increase the amount of memory allocated to the audio buffer, or reduce the amount of data flowing into it. The simple solution is the second option. We can easily do that by cutting the audio bit rate in half.

    instead of this:

    audio_out_rate=44100
    audio_driver=sdl

    do this:

    audio_out_rate=22050
    audio_driver=sdl

    you could also try this:

    audio_out_rate=24000
    audio_driver=sdl

    These are industry standard bit rates, try to stick to them or you may end up with strange audio artifacts or changes in pitch for music and sound effects.

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

    • This reply was modified 1 year, 11 months ago by Profile photo of labelwhore labelwhore.
    • This reply was modified 1 year, 11 months ago by Profile photo of labelwhore labelwhore.
    • This reply was modified 1 year, 11 months ago by Profile photo of labelwhore labelwhore.
    • This reply was modified 1 year, 11 months ago by Profile photo of labelwhore labelwhore.
    #97112
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    this is awesome! thank you! I’ll try these when I get home from work!

    thank you

    #97115
    Profile photo of labelwhore
    labelwhore
    Participant

    With those settings, the audio may be a bit “crunchier” but heh, it’ll help add some vintage charm. 🙂

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar