After uploading ROMs, system fails automatic file system check

Home Forums RetroPie Project Everything else related to the RetroPie Project After uploading ROMs, system fails automatic file system check

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 5 replies, has 4 voices, and was last updated by Profile photo of InsecureSpike InsecureSpike 2 years ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #86672
    Profile photo of
    Anonymous

    Setup my retropie using guides on this site. I’ve done it in the past without any issues. After I get the initial setup done, I always take an image of the SD card using HDD Raw Copy, so I can reimage incase of any issues.

    Recently I’ve been having an issue where after I move ROMs over to the retropie, and restart the system (using the onscreen menu), the system reboots and I get this error message:

    “an automatic file system check (fsck) of the root filesystem failed.”

    Doing a manual filesystem check doesn’t help. The filesystem seems irreparably damaged. I use HDD Raw Copy to reimage the disk and start over.

    I tried being super careful moving the files over. I first tried Samba, then SSH, then a physical USB drive copy. All of them cause the same issue.

    Anyone know what I might be doing? This is a Raspberry Pi B+, so I, unfortunately, don’t have any spare MicroSDs to test.

    #86675
    Profile photo of herbfargus
    herbfargus
    Moderator

    I’m not sure how helpful this will be but I ended up corrupting the microsd card somehow and it wouldn’t boot, it gave a similar response. Other times it would hang on the rainbow splash screen.
    A few things to check:

    -make sure you have an adequate power supply (mine is 2a 5v) but I’ve seen people do with less.

    -if you compiled it yourself it could have been an error in the setup process otherwise try redownloading the SD card image petrockblog supplies

    -try using win32diskimager instead of hddrawcopy

    – I ended up corrupting things trying to transfer ROMs with a USB stick with image 2.4.2 beta as a result of the usbromservice not being configured properly (I don’t know if that has been fixed yet or not) but you can update the usbromservice from the setup script if it hasn’t been fixed.

    -check to see if your microsd card is compatible http://elinux.org/RPi_SD_cards

    In my case I guess I broke things beyond repair and ended up needing a new microsd card. I bought a new 32 gb sandisk ultra from amazon, downloaded the SD card image 2.4.2 off of petrockblog and used win32diskimager to put the image on the microsd card, updated the usbromservice from the setup script (cd RetroPie sudo .retropie_setup.sh) and it worked for me.

    • This reply was modified 2 years, 2 months ago by Profile photo of herbfargus herbfargus.
    #86676
    Profile photo of
    Anonymous

    Thanks for the reply!

    Just to be clear, I used win32diskimager to write the initial image to the MicroSD. It was after setting up my controllers, configurations, etc. that I made the image with HDD Raw Copy.

    I also have a 2a 5v power supply. Sucker cost me $13, but I’ve had issues with lesser ones.

    The USB transfer was the last thing that I tried, and it did corrupt the card, but so did samba and ssh.

    I found a 4gb MicroSD card and I’m going to try that one from scratch. It won’t hold all the ROMs, but it will be a good test.

    #86678
    Profile photo of herbfargus
    herbfargus
    Moderator

    Good to know, let me know what you figure out.
    (in case you weren’t aware win32diskimager also can create sd images by clicking read instead of write. You just have to name the file first with a .img ending.)

    #94618
    Profile photo of phrazelle
    phrazelle
    Participant

    This just happened to me. I am running RP3.0 on a Pi 2 from USB. I was scraping metadata and did a reboot from within ES. When it rebooted it threw this message along with a few lines about a different rooms taking up extra or duplicate blocks.

    I fixed it by running as root:

    fsck /dev/sda2

    While checking my drive, there were a few errors and I told it to fix them as they came up. After that a reboot occurred and it is good to go.

    I would assume this would also work if running off SD by replacing sda2 with the address of the card? Barring the card being trashed, though.

    #94619
    Profile photo of InsecureSpike
    InsecureSpike
    Participant
Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar