Adding exit button for emulators

Home Forums RetroPie Project Everything else related to the RetroPie Project Adding exit button for emulators

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 4 replies, has 3 voices, and was last updated by Profile photo of kanemack kanemack 2 years, 1 month ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #91160
    Profile photo of kanemack
    kanemack
    Participant

    I have been searching for a while now, and have seen some helpful stuff,but still have not solved my problem. The problem is that when editing the config folder for retroarch, it only contains keyboard code. Where do I put the input line for exit with a joystick?

    My setup is:

    RP2 with retropie 2.6(latest if I’m wrong)

    I know the answer is a line or 2 of code, but I’m new to this so be gentle.

    Edit: I forgot to mention, I’m using a wired XB1 controller

    • This topic was modified 2 years, 1 month ago by Profile photo of kanemack kanemack.

    #91172
    Profile photo of muriani
    muriani
    Participant

    Have you tried pressing select+start simultaneously? I think that’s setup as exit code by default.
    It’s worked with all the libretro modules I’ve tried so far.

    #91173
    Profile photo of muriani
    muriani
    Participant

    This may help point you in the right direction as well if you just want to use say, the guide button to exit: https://github.com/retropie/RetroPie-Setup/wiki/Advanced-Configuration

    #91179
    Profile photo of Floob
    Floob
    Moderator

    This may help you setup an exit button combination to use from your joypad.

    You will want to edit the xbox controller file in:
    /opt/retropie/emulators/retroarch/configs/

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #91307
    Profile photo of kanemack
    kanemack
    Participant

    Thanks for the help guys, but after the post I have not been able to get ES to work on a new install so until then, I hope these solve the exit problem.

    I posted the problem here.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar