A pretty dark problem

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 10 replies, has 4 voices, and was last updated by Profile photo of atimmins atimmins 2 years, 9 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #9888
    Profile photo of locomat
    locomat
    Participant

    Hi guys,

    I just installed the Retropie on my Pi…it works just fine but…

    When I start a ROM in the SNES emulator (pocketsnes) the games are way to dark…for example in Castlevania 4 I cant even see the background.

    The GUI is perfect its just the ROM that are dark.

    Is there any way to setup the brightness of the emulators/ROMS?

    If I use pisnes the colours are perfect but for some reason I cant set up the controls but thats another problem. I would really want pocketsnes to work….

    Hope that someone can help me!!!!

    #10475
    Profile photo of atimmins
    atimmins
    Participant

    I am having the exact same problem. It only seems to affect certain SNES roms, and some worse than others. I also tried switching to pisnes but something was wrong with the input configuration since pressing specific buttons gave the wrong action. I couldn’t figure out how to fix that so I am back to the default emulator.

    #10553
    Profile photo of atimmins
    atimmins
    Participant

    I never did figure out how to get pisnes to work, but think I got the dark picture problem fixed in the default emulator. I disabled video shaders and enabled smoothing in the retroarch config in the all folder and in each emulator config file. For whatever reason, that seems to have solved my dark image problem. Hopefully this helps, locomat.

    #10648
    Profile photo of nemo93
    nemo93
    Participant

    hi!!
    You should give a try to piSNES. Great compatibility and works like a charm. At least the behavior you described never occured with this emulator. I believe you just have to comment out the proper line in the es_systems.cfg file.

    hope this helps.

    #11671
    Profile photo of atimmins
    atimmins
    Participant

    Yes, I did that already. I got pisnes running, but the problem is that it appears that pisnes doesn’t pay any attention to the retroarch.cfg file and the controls don’t match my snes controller. Then I tried re-installing pisnes from source to actually get a config file and after that it wouldn’t run.

    #12072
    Profile photo of nemo93
    nemo93
    Participant

    hey atimmins,

    piSNES comes with its own configuration file. It’s named “snes9x.cfg” and you’ll find it under the pisnes directory in “/opt/retropie/emulators/”.

    it’s really weird (again) as I can’t reproduce this. Perhaps you could try downloading another version of this game? to be sure.

    cheers,

    #12091
    Profile photo of smatticus
    smatticus
    Participant

    how can a noob like me launch piSnes? and is there a way to make it the default emulator in emulationstation over pocketsnes? i don’t have any darkness issues, but there does seem to be some stuttering in a good portion of roms (kirby’s dreamland 3 and super metroid). if pisnes offers improvement i’d like to try it. could someone please help?

    #12229
    Profile photo of nemo93
    nemo93
    Participant

    hi smatticus,

    to make piSNES the default simply edit the “es_systems.cfg” file and spot the Super Nes section. Amend it like this:

    <system>
            <fullname>Super Nintendo</fullname>
            <name>snes</name>
            <path>~/RetroPie/roms/snes</path>
            <extension>.smc .sfc .fig .swc .SMC .SFC .FIG .SWC .zip .ZIP</extension>
            <command>/opt/retropie/emulators/pisnes/snes9x %ROM%</command>
            <platform>snes</platform>
            <theme>snes</theme>
        </system>
    

    hope this helps.
    cheers,

    #13108
    Profile photo of atimmins
    atimmins
    Participant

    Just an update for the original poster; I had the same problem with the backgrounds being too dark. Apparently it is only the default video shader in retroarch that makes this happen. Change the shader to something else and it should solve your problem. I prefer the shader hq2x2. I noticed that leaving video smoothing turned off resulted in better performance.

    #13525
    Profile photo of locomat
    locomat
    Participant

    Thanks for the hint with the shader!

    It works perfect but how can I save the setting? Everytime I quit a game and select a different one the setting are default and I have to activate the shader again.

    I really like the shader option it makes the games look really good!!!

    #13821
    Profile photo of atimmins
    atimmins
    Participant

    Try editing the config file at opt/retroarch/emulators/snes/retroarch.cfg. That’s how I did it.

Viewing 11 posts - 1 through 11 (of 11 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar