A few issues with RetroPie

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

Tagged: 

This topic contains 5 replies, has 3 voices, and was last updated by Profile photo of Floob Floob 2 years, 3 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #67615
    Profile photo of kenno7
    kenno7
    Participant

    Hello,

    I have just started using RetroPie in the last week.
    I find it quite easy to use and setup.

    Just having a couple issues that I was wanting to get some help with.

    1) I have a wireless PS3 controller. It is setup and working when the usb cable is plugged in. However, when trying to set it up through bluetooth I can’t get it working. I’ve followed several guides and looked for solutions but am stuck when I type in : sudo ./sixpair

    I get an error saying “usb_claim_interface: Device or resource busy”

    Has anyone else had this / know how to fix it?

    2) I can’t play MAME games. They appear in the list of ROMs but when I try to play it I get an error saying:

    opt/retropie/supplementary/runcommand/runcommand.sh: line 60: /opt/retropie/emulators/mame4all-pi/mame: no such file or directory

    Do you know how I can fix this?

    3) I can’t get save states, load states and print screens working in any of my emulators. I have configured retroarch.cfg to say :

    input_save_state = n
    input_load_state = m

    But it does nothing… Is anything else meant to be setup for this?

    4) Not a major thing but every ROM I open there is a message that appears on the screen saying Joypad port #0 (Xbox Gamepad (userspace driver)) configured

    Is there a way to stop this message coming up?

    Thanks for your help 🙂

    #69174
    Profile photo of kenno7
    kenno7
    Participant

    I managed to resolve the first issue by uninstalling the xbox 360 driver that the ps3 controller was currently using

    sudo apt-get remove xboxdrv

    I still don’t have it working though… When trying to pair with sixad I get :

    @retropi ~ $ sudo sixad –start
    sixad-bin[3558]: started
    sixad-bin[3558]: sixad started, press the PS button now
    sixad-sixaxis[3562]: started
    sixad-sixaxis[3562]: Connected ‘PLAYSTATION(R)3 Controller (00:19:C1:F9:4E:51)’ [Battery 00]

    I’ve read that it may be the bluetooth adapter though. I’ve ordered another couple of them so will give that a go when they arrive unless anyone knows a solution / another cause for this ?

    Still stuck with the other things I’ve mentioned in the original post though..

    Any help would be appreciated.

    Thanks 🙂

    #74326
    Profile photo of kenno7
    kenno7
    Participant

    Okay .. Half way through solving another one of my issues..

    Save and Load states now seem to work BUT only if I have a hotkey set…
    I don’t want to use a hotkey….
    I just want them to work!

    I’ve tried setting input_enable_hotkey = “nul”
    But that won’t let me save, load, exit or anything!

    I’ve tried putting multiple values for it in like
    input_enable_hotkey = n
    input_enable_hotkey = m
    input_enable_hotkey = escape

    But that will just use whichever line is on top in the cfg file as the hotkey

    A strange issue seems to be happening aswell… I’ve set my screenshot key to ‘e’
    When I press the hotkey + e it does screenshot but also puts the emulation into Slow Motion. I’ve tried commenting out the Slow Motion part of the config file AND removing the lines all together but it still works….

    Is there something I’m missing here?

    Would really appreciate it if someone could give me a hand.

    Thanks

    #80212
    Profile photo of kenno7
    kenno7
    Participant

    bump . . .

    #85783
    Profile photo of kiwijam777
    kiwijam777
    Participant

    Same Mame ROM issue. Must be in .zip folders.to get them to work. I found I had to rename .ZIP to .zip (lowercase) to get them to work. Had to make sure no upper case anywhere in filename. not sure if you have the same issue but that resolve my issue.

    For hotkeys, I disabled them by using “input_enable_hotkey = false” and disabled hotkey button “#input_enable_hotkey_btn = ” 8″ “. _btn is for joysticks and controllers. Without _btn is for keyboard. With this configuration in have dedicated buttons to load, save, reset, exit emulator, vol up, and vol down.

    #85812
    Profile photo of Floob
    Floob
    Moderator

    This may help as a hotkey overview

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar