5-button bluetooth controller not working in emulators

Home Forums RetroPie Project Controller Configuration in RetroPie 5-button bluetooth controller not working in emulators

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 1 reply, has 1 voice, and was last updated by Profile photo of kinsago kinsago 1 year, 3 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #114966
    Profile photo of kinsago

    System Spec:
    Pi B+ (not currently overclocked)
    Retropie 3.2 (for reasons below)
    Controller: LianLe Bluetooth controller:

    Hi all,

    I’ve got Retropie up and running and paired the above controller. I’m using v3.2 as anything higher would pair with the controller but not necessarily recognise it as a controller.

    The controller works fine through emulationstation however once in a game only the directional pad works, the buttons do nothing.

    I’ve tried reconfiguring the controller in retroarch as well as emulationstation but no joy. I’ve also tried manually adding the config to retroarch.conf

    Any help would be greatly appreciated.


    Profile photo of kinsago

    Ok, so after more searching, testing and generally messing around, I found this:

    It indicates that the issue is the driver in use. I’ve made a few tweaks and did manage to get the megadrive emu to recognise the buttons ingame. This needs testing further and so I’m quite finished with this post yet.

    Sadly my BT controller has a dead battery now and so I can’t finish testing quite yet….

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar