3.5" adafruit tft screen compatibility with retropie

Home Forums RetroPie Project Everything else related to the RetroPie Project 3.5" adafruit tft screen compatibility with retropie

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

Tagged: 

This topic contains 20 replies, has 5 voices, and was last updated by Profile photo of wilsonb wilsonb 1 year, 7 months ago.

Viewing 21 posts - 1 through 21 (of 21 total)
  • Author
    Posts
  • #93604
    Profile photo of bassholio
    bassholio
    Participant

    I have just started tinkering with this…unsuccessfully.. Any pointers?

    #93605
    Profile photo of albill
    albill
    Participant

    You looked in the Adafruit forums right.

    https://forums.adafruit.com/viewtopic.php?f=19&t=69115&p=350571

    #93630
    Profile photo of bassholio
    bassholio
    Participant

    Yeah I saw that and was hoping that there may have been some more details on how to make it work. I followed the instructions I found and still have a white screen.

    #95313
    Profile photo of trixster
    trixster
    Participant

    Did you get this to work? I have a pitft 3.5 on an rpi2 and I think it works brilliantly!

    #95315
    Profile photo of bassholio
    bassholio
    Participant

    No I didn’t. Are you running retropie?

    #95349
    Profile photo of trixster
    trixster
    Participant

    Yes. I followed this tutorial https://learn.adafruit.com/running-opengl-based-games-and-emulators-on-adafruit-pitft-displays/pitft-setup

    You have to substitute 28r for 35r.

    The line: /usr/local/bin/fbcp &

    Needs to be added to /etc/rc.local

    In config.txt you need to add this line: dtoverlay=pitft35r,rotate=90,speed=80000000,fps=60

    and comment out a similar line which has been added by the helper script.

    #95352
    Profile photo of trixster
    trixster
    Participant

    • This reply was modified 2 years ago by Profile photo of trixster trixster.
    #95361
    Profile photo of bassholio
    bassholio
    Participant

    Tgabk you. I’ll give it another shot. Is the feamwrate low in your opinion?

    #95365
    Profile photo of trixster
    trixster
    Participant

    That video was taken before I commented out the line: dtoverlay=pitft35r,rotate=90,speed=42000000,fps=20

    in config.txt and replaced it with

    dtoverlay=pitft35r,rotate=90,speed=80000000,fps=60

    It’s smoother now.

    The rpi2 is overclocked to 1.1ghz, sdram at 483, core not overclocked.

    #95645
    Profile photo of trixster
    trixster
    Participant

    Slightly better video here:

    #95828
    Profile photo of clpalmer
    clpalmer
    Participant

    trixter: Any time I try and push up the PITFT speed to 80 (or even 64) it gets a bit glitchy and flashes white for a split second on a fairly frequent basis. The only frequency I’ve got it to work at is 48000000. Anything higher causes the glitches. At that frequency, the display is solid, but the emulation is laggy. At 80000000, emulation is smooth, but the display glitches.

    Did you see that same behaviour or do you have any suggestions?

    #95846
    Profile photo of bassholio
    bassholio
    Participant

    Why is the target 60? Why not 24 or 30fps?

    #95847
    Profile photo of clpalmer
    clpalmer
    Participant

    I tried dropping it down to 30 (along with the HDMI refresh rate) and it was quite sluggish. Not sure if there’s just a sleep somewhere to suck up the other 30 frames, but it was definitely worse.

    #95868
    Profile photo of trixster
    trixster
    Participant

    Hello all,

    80000000 works fine on my pitft, I can’t discern any glitches, flashes or flickers. There’s little or no input lag. I went with the adafruit settings purely because that’s what they recommended for the 2.8 screens and they seem to work fine with my 3.5. Regarding the fps – I’m not sure why there’s an fps setting however I was happy enough to stick with 60fps as it correlates with the refresh rate of most of the emulators I’m using. I’m not sure why a tft would have both a refresh and an fps setting though.

    #95869
    Profile photo of trixster
    trixster
    Participant

    Bassholio, did those files I sent you make any difference?

    #95871
    Profile photo of bassholio
    bassholio
    Participant

    I haven’t had a chance to try them yet. Hopefully today.

    #95916
    Profile photo of clpalmer
    clpalmer
    Participant

    bassholio: mind posting/sending your config.txt and/or any other tweaks you’ve made? I’m assuming I just have a closer-to-spec display that can’t handle the higher freq’s, but would be nice to check against whatever else you might have done.

    #100002
    Profile photo of wilsonb
    wilsonb
    Participant

    Raspberry Pi 2
    Adafruit 3.5 PiTFT

    Same problem, screen is extremely shaky/wavy, and now my HDMI says out of sync(no display on monitor)
    BTW: Should this be at this resolution, since the pitxt is a 480
    hdmi_cvt=320 240

    config.txt
    # for more options see http://elinux.org/RPi_config.txt
    gpu_mem_256=128
    gpu_mem_512=256
    gpu_mem_1024=384

    overscan_scale=1
    gpu_mem=64
    dtparam=spi=on

    hdmi_force_hotplug=1
    hdmi_cvt=320 240 60 1 0 0 0
    hdmi_group=2
    hdmi_mode=87
    # — added by adafruit-pitft-helper Wed Jun 17 10:30:02 CDT 2015 —
    [pi1]
    device_tree=bcm2708-rpi-b-plus.dtb
    [pi2]
    device_tree=bcm2709-rpi-2-b.dtb
    [all]
    dtparam=spi=on
    dtparam=i2c1=on
    dtparam=i2c_arm=on

    # dtoverlay=pitft35r,rotate=90,speed=42000000,fps=20
    # — end adafruit-pitft-helper Wed Jun 17 10:30:02 CDT 2015 —

    dtoverlay=pitft35r,rotate=90,speed=80000000,fps=60

    • This reply was modified 1 year, 10 months ago by Profile photo of wilsonb wilsonb.
    #100067
    Profile photo of wilsonb
    wilsonb
    Participant

    Got it figured out by changing config.txt . (Lowering the speed= )
    Here is my config.txt for others with 3.5 LCD.


    # — end adafruit-pitft-helper Wed Jun 3 03:41:41 UTC 2015 —
    arm_freq=1000
    #core_freq=500
    sdram_freq=483
    over_voltage=6

    dtparam=i2c1=on

    #- added by adafruit-pitft-helper Wed Jun 17 17:26:46 CDT 2015 —
    [pi1]
    device_tree=bcm2708-rpi-b-plus.dtb

    [pi2]
    device_tree=bcm2709-rpi-2-b.dtb

    [all]
    dtparam=spi=on
    dtparam=i2c_arm=on

    dtoverlay=pitft35r,rotate=90,speed=49700000,fps=60

    #100069
    Profile photo of wilsonb
    wilsonb
    Participant

    I would like to fill the LCD as much as possible/biggest so it’s usable.

    The only way I found so far is modifying the opt/retropie/configs/mame-mame4all/mame.cfg file;

    [config]
    artwork=yes
    samples=yes
    antialias=yes
    translucency=yes
    skiplines=0
    skipcolumns=0
    beam=1.0
    flicker=0.0
    gamma=1.0
    frameskip=auto
    ror=no
    rol=no
    flipx=no
    flipy=no
    samplerate=44200
    volume=0
    cheat=no
    #vector_width=640
    vector_width=480
    #vector_height=480
    vector_height=320

    kioskmode=no
    force_stereo=no
    # Anti-alias the display?
    display_smooth_stretch=yes
    # Stretches to fill screen (ONLY if display_smooth_stretch is enabled)
    display_smooth_stretch_full=yes
    display_border=0
    # display effect postprocessing: 0 none, 1 scanlines
    display_effect=0
    #Set a static resolution
    #resolution=400×240
    #resolution=480×320
    resolution=320×250
    #resolution=360×228

    #104927
    Profile photo of wilsonb
    wilsonb
    Participant

    Went to RetroPi 3 using Raspberry Pi 2 + Adafruit piTFT 3.5 (480×320)

    And now can’t get LCD dispolay to work. I think it’s a new kernel.

    Anyone get this exact config to work?

Viewing 21 posts - 1 through 21 (of 21 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar