3.2 wireless xbox 360 controller now controls both p1 and p2

Home Forums RetroPie Project Controller Configuration in RetroPie 3.2 wireless xbox 360 controller now controls both p1 and p2

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 1 reply, has 1 voice, and was last updated by Profile photo of kirederf77 kirederf77 1 year, 5 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #110548
    Profile photo of kirederf77
    kirederf77
    Participant

    So since I updated to the new version of retropie my p1 xbox 360 controller now controls both p1 and p2 at the same time while the 2nd controller is recognized it doesn’t do anything anymore…

    I hope some of you guys can help me out…

    Here’s my retroarch.cfg:

    input_player1_analog_dpad_mode = “1”
    input_player2_analog_dpad_mode = “1”
    input_player3_analog_dpad_mode = “1”
    input_player4_analog_dpad_mode = “1”
    input_player5_analog_dpad_mode = “1”
    input_player6_analog_dpad_mode = “1”
    input_player7_analog_dpad_mode = “1”
    input_player8_analog_dpad_mode = “1”

    input_enable_hotkey = nul
    input_player1_joypad_index = “0”
    input_player1_b_btn = “4”
    input_player1_y_btn = “6”
    input_player1_select_btn = “12”
    input_player1_start_btn = “13”
    input_player1_up_btn = “0”
    input_player1_down_btn = “1”
    input_player1_left_btn = “2”
    input_player1_right_btn = “3”
    input_player1_a_btn = “5”
    input_player1_x_btn = “7”
    input_player1_l_btn = “8”
    input_player1_r_btn = “9”
    input_player1_l2_btn = “10”
    input_player1_r2_btn = “11”
    input_player1_l3_btn = “15”
    input_player1_r3_btn = “16”
    input_player1_l_x_plus_axis = “+0”
    input_player1_l_x_minus_axis = “-0”
    input_player1_l_y_plus_axis = “+1”
    input_player1_l_y_minus_axis = “-1”
    input_player1_r_x_plus_axis = “+2”
    input_player1_r_x_minus_axis = “-2”
    input_player1_r_y_plus_axis = “+3”
    input_player1_r_y_minus_axis = “-3”

    input_player2_joypad_index = “0”
    input_player2_b_btn = “4”
    input_player2_y_btn = “6”
    input_player2_select_btn = “12”
    input_player2_start_btn = “13”
    input_player2_up_btn = “0”
    input_player2_down_btn = “1”
    input_player2_left_btn = “2”
    input_player2_right_btn = “3”
    input_player2_a_btn = “5”
    input_player2_x_btn = “7”
    input_player2_l_btn = “8”
    input_player2_r_btn = “9”
    input_player2_l2_btn = “10”
    input_player2_r2_btn = “11”
    input_player2_l3_btn = “15”
    input_player2_r3_btn = “16”
    input_player2_l_x_plus_axis = “+0”
    input_player2_l_x_minus_axis = “-0”
    input_player2_l_y_plus_axis = “+1”
    input_player2_l_y_minus_axis = “-1”
    input_player2_r_x_plus_axis = “+2”
    input_player2_r_x_minus_axis = “-2”
    input_player2_r_y_plus_axis = “+3”
    input_player2_r_y_minus_axis = “-3”

    #110553
    Profile photo of kirederf77
    kirederf77
    Participant

    I’m such a retard…
    input_player2_joypad_index = “0”
    should be
    input_player2_joypad_index = “1”

    How did that change though? Weird..

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar