2.3 custom Themes… I keep breaking the…

Home Forums RetroPie Project Everything else related to the RetroPie Project 2.3 custom Themes… I keep breaking the…

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of wrichards wrichards 2 years, 6 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #81601
    Profile photo of wrichards
    wrichards
    Participant

    I got 2.3 running well on the B+ and am now trying to customize the THEMES, mainly the backgrounds of the emulators… Im NOT talking about the blured ones but the background inside each emulator. I want a diffrent pic for each emulator. Now I found that I can change the “mid.png” file under /simple/art and it will change ALL the backgrounds of all the emulators.. thats ok, but i want to have a diffrent background for each emulator.

    I tryed editing the theme.xml for each specific emulator but I cant seem to edit it right as i break the background of the “blurred” image and it shows as a blank white but inside the emulator the background is changed to what I want. what I want…

    I added this to the theme.xml

    <image> name=”background”>
    <pos>0 0</pos>
    <origin>0 0</origin>
    <size>1 1</size>
    <path>/etc/emulationstation/themes/simple/atari2600/art/mid.png</path>
    </image>

    after changing the mid.png to what I wanted… It works but breakes the “blurred” background one screen back…

    any help on where or how to change this to have a diffrent background insode each emulator screen? I just cant find the call out to mid.png outside each theme.xml I just want each emulator backgorund to be diffrent, Im NOT talking about the “blurred” ones, and I know ive got a conflict somewhere…

    This is the last thing I wanta do and Im done, any help would be apreciated…

    if anyone could post thier theme.xml of a emulator with a custome background and working blurred. it would relly help…
    thanks again in advance

    • This topic was modified 2 years, 6 months ago by Profile photo of wrichards wrichards.

    #81628
    Profile photo of Keigan
    Keigan
    Participant

    There are 2 background files in your xml file.

    To make a different background for each emulator you need to change the background link under <view name=”basic, detailed”>.

    Under <view name=”system> you need to leave the path to your blur photo.

    Here is the first part of my custom theme xml file.

    <view name=”system”>
    <image name=”background” extra=”true”>
    <path>./art/nes_main.jpg</path>
    </image>

    <image name=”logo”>
    <path>./art/nes2.svg</path>
    </image>
    <helpsystem name=”help”>
    <fontSize>0.02</fontSize>
    <fontPath>./../art/tradegothic.ttf</fontPath>
    <textColor>2F2F2F4D</textColor>
    <iconColor>2F2F2F4D</iconColor>
    <pos>0.01 0.975</pos>
    </helpsystem>
    </view>
    <view name=”basic, detailed”>
    <image name=”background” extra=”true”>
    <path>./art/nes.png</path>
    <size>0 1</size>
    <pos>0.5 0.5</pos>
    <origin>0.5 0.5</origin>
    </image>

    </view>

    As you can see I have 2 backgrounds set up. 1 For the main screen and 1 for the game list section.

    Hope this helps.

    #81633
    Profile photo of wrichards
    wrichards
    Participant

    Thank you mucho, trying it now… 🙂

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar