Reply To: Dreamcast

#122354
Profile photo of stakstar
stakstar
Participant

In addition to hyell’s fix I found that the:

/opt/retropie/configs/all/autoconf.cfg has reicast set to an input of 1. I changed it to 4.

# this file can be used to enable/disable retropie autoconfiguration features
mupen64plus_audio = 1
mupen64plus_hotkeys = 1
mupen64plus_compatibility_check = 1
reicast_input = 4 
es_swap_a_b = 0

after changing the input number in the above file I put in my input device info:

/opt/retropie/configs/dremcast/emu.cfg


backend = oss
disable = 0

[config]
Debug.SerialConsoleEnabled = 0
Dreamcast.Broadcast = 4
Dreamcast.Cable = 3
Dreamcast.RTC = 1543276800
Dreamcast.Region = 3
Dynarec.Enabled = 1
Dynarec.idleskip = 1
Dynarec.unstable-opt = 0
aica.LimitFPS = 1
aica.NoBatch = 0
aica.NoSound = 0
bios.UseReios = 0
joystick_device_id_2 = -1
pvr.MaxThreads = 3
pvr.Subdivide = 0
pvr.SynchronousRendering = 0
pvr.rend = 0
rend.UseMipmaps = 1
rend.WideScreen = 0
ta.skip = 0

[input]
evdev_device_id_1 = 6
evdev_device_id_2 = 7
evdev_device_id_3 = -1
evdev_device_id_4 = -1
evdev_mapping_1 = /opt/retropie/configs/dreamcast/mappings/controller_XboxGamepad(userspacedriver).cfg
evdev_mapping_2 = /opt/retropie/configs/dreamcast/mappings/controller_XboxGamepad(userspacedriver).cfg
joystick_device_id = -1

[reios]
ElfFile = 

[validate]
OpenGlChecks = 0

Before changing the input number whenever I would reset my device_id’s and device_mappings this information it would go back to the default values whenever I started the dreamcast emulator.

I’m using 2 wireless Xbox 360 controllers and both are working on Power Stone in the dreamcast emulator.
I hope this helps anyone trying to get this going.

Skip to toolbar