Reply To: SNES emulator issues

#114341
Profile photo of mw99
mw99
Participant

Yeh after some further testing – there is little difference really – and the previous code has audio interpolation which sounds better (slightly slower, but not much).

I am going to revert back to the upstream code, but overclock your rpi more and it should be better. also you can try configuring “runcommand” from the retropie-setup setup / configuration menu and set governor to performance which might help too). If it’s fine on ondemand though leave it like that.

can also try the dispmanx video output driver. go to retropie-setup / setup / configuration menu and go to config editor. edit common options / all/retroarch.cfg and set video_driver to “dispmanx”

to improve rpi audio via jack, and remove background hiss you can try adding disable_audio_dither=1 to /boot/config.txt

overclocking more is the best bet though imho.

Thanks for the help. I’ll try your suggestions and let you know how it goes.

I don’t want to increase my overclock because all the ones above “Modest” include overvolting, which I am not comfortable with doing to my Pi.

(Is there a way for me to save this older version of lr-pocketsnes in case I ever have to re-flash my card?)

Skip to toolbar