RetroPie 3.6 is Released

Pixel-ArtRetroPie on Raspberry Pi 3? Get RetroPie 3.6!

This version is released a little earlier than originally planned, due to the release of the fantastic Raspberry Pi 3 – which our previous 3.5 will not boot on due to having out of date firmware. Along with Raspberry Pi 3 compatibility this release brings a bunch of interesting experimental emulators such as Daphne for emulation of classic LaserDisc arcade games, a myriad of libretro cores, and a few game engines. We’ve also worked around the pesky insert coin bug that has plagued the arcade emulators.

You can find the links for the SD-card images as usual in the Downloads Sections.
Installation Instructions can be found at Github: https://github.com/RetroPie/RetroPie-Setup/wiki/First-Installation

Changes since 3.5:

Added Support for the Raspberry Pi 3

  • Added new experimental modules:
    • Daphne (Laserdisc Emulator)
    • Libretro-QuickNES
    • Libretro-Beetle PSX (x86 only)
    • Libretro-Beetle Lynx
    • GemRB engine (Baldur’s Gate, Icewind Dale, Planescape)
    • ResidualVM (Engine for Grim Fandango and Escape from Monkey Island)
    • Libretro-MESS (based on the most recent version of MAME)
    • Libretro-MAME (based on the most recent version of MAME)
  • Added EmulationStation theme Simpler Turtle Pi to the theme installer from Omnija.
  • Added version details and uninstall option to the RetroPie Setup Script.
  • Fixed insert coin not working on arcade based emulators.
  • Various other bugfixes and improvements.

Check Also

New Revision of the PowerBlock: Increased Flexibility

The PowerBlock is a small support shield for the Raspberry Pi that provides a power …

  • Jeroen

    Nice! Just a quick question, do I have to reinstall the whole image to make use of the Wi-Fi in my Rpi3? Or can I just use the RetroPie Update script?

    • Zogzoghakita

      I’m also deeply interested in such information to know if I can easily update from 3.2 to 3.6 on Raspberry 2.

    • Dan Smith

      Im curious about this as well. I just installed version 3.1 via berryboot. Can i run updater script to update to 3.6 or do i need to download the image and install it that way?

  • Capeman29

    What is this “Libretro-MAME (based on the most recent version of MAME)” – I’m not seeing it on the mame documentation page. Is it an update to lr-mame-2010 or is it a whole new core based literally on mame 0.171? That would be awesome if it was!

    • i64X

      0.171, or even 0.170 would make me SO happy. I just had to manually update my set last night from 0.147 to 0.170. It look hours.

      • Hugh Jwang

        do .170 / .171 roms work on retropie???

      • i64X

        No. I updated them for another project.

  • -T.G.O.K-

    Was Steven Selph’s Scraper removed from the retropie setup ?

    • i64X

      It looks like it. I upgraded yesterday and didn’t see that as an option in the “experimental” section, or whatever it’s called.

      • -T.G.O.K-

        Found it under Setup/Configuration above experimental packages option 319. If anyone else was wondering 🙂

  • Tom Lone Hero

    Is the saturn yabause any usable with a pi 3 ?

  • Ron

    does the n64 roms run better on the Pi 3?

    • yes seen on youtube

    • Joseph Dykes

      I have seen literally 0% improvement.

  • Pingback: Get RetroPie 3.6 on Raspberry Pi 3! #piday #raspberrypi @Raspberry_Pi « Adafruit Industries – Makers, hackers, artists, designers and engineers!()

  • Pingback: Get RetroPie 3.6 on Raspberry Pi 3! #piday #raspberrypi @Raspberry_Pi - Raspberry Pi News()

  • BK

    There’s another place I can download the image? Downloading at 15 kb/s is really frustrating.

  • KissiKi

    After installing 3.6 release and upgrading it via apt-get upgrade system can not connect ssh and only show first screen with gamepad settings.

  • Joseph Dykes

    Some of the issues I’m having right off the bat are Selph’s scraper seems to not be functioning properly even if run from command. Over clock settings can not be set from raspi-config. Emulators and roms on pi 3 seem to have the same performance as pi 2 running 3.6. I’m Not a linux master so these critiques are from a User interface perspective. You guys are amazing by the way… but you already knew that… my arcade cabinet thanks you.

    • Joseph Dykes

      Got the scraper working after a few tries…not having any luck with emulation improvements if anyone knows a good way to setup the pi3.

      • Tejas Melkote

        Hi. I’m having trouble with sselph scraper as well. Even with command line. Could you pls tell me how you got the scraper working? I get a message saying – Fatal: unable to access ‘https://github.com/sselph/scraper’ : server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none.
        Help appreciated. Thanks in advance
        By the way, running RetroPie3.6 on Rpi3

    • Joseph Dykes

      after a little testing I’m still not seeing any improvement in emulation or even game streaming. PSP,PSX,N64,Moonlight all run exactly how they did on the pi 2. Is there a setting in the command line i need to input? Any help would be greatly appreciated.

  • bazinga vegas

    Have they added the ability to easily use USB storage with retropie yet? I switched to a different distro just because of that but would like to use retropie as it has more emulators.

    thanks

    • smartroad

      I have a USB memory stick formatted to ext4 and mounted where RetroPie expects the roms to be. Think there is a guide in the forum 🙂

  • Luiz Fernando

    Hi retropie accept snes control direct GPIO?

  • Dolf Muccillo

    First of all great job on this! Second, a request, Is there any chance a future release could offer built-in support for the X-arcade Tankstick? I have tried installing Xarcade2Jstick per the instructions on your site but have been unable to get it to work. Thanks!

    • jacobpederson

      I second this, just picked up the TankStick also. Thanks!

  • Kris Mettelmann

    Has anybody had any luck with the rom-specific settings override you can set during the runcommand? What I’m trying to do with lr-fba-next is have galaga.zip for example override the video_aspect_ratio. In my master retroarch config, i have it so games load as 16:9, which I don’t mind for those games, but it’s ridiculous for vertical games.

  • Marcello

    hi all…lots of compliments to the Retropie staff: great work!
    I have a strange controller problem in mame4all emulator under Retropie 3.6.
    I have built an arcade joystick with a Xin-mo controller.. for 1 player.
    After the first configuration, my joystick works well with Neo-Geo and Libretro, but when i lunch mame4all emulation, buttons works well but the stick doesnt works.
    Suggestions?
    Im sorry for my bad english, i hope you understand…

  • Tejas Melkote

    Hi. Can anyone help me? I’m having trouble with sselph scraper. Even with command line. I get a message saying – Fatal: unable to access ‘https://github.com/sselph/scraper’ : server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none.
    Help appreciated. Thanks in advance
    By the way, running RetroPie3.6 on Rpi3

    • Joseph Dykes

      Hi Tejas. I did not see the error i received when the scraper failed on the first couple attempts, it just quit back to Retropie Setup. the scraper worked for me miraculously on the third attempt. The only thing I could have done was “sudo apt-get update and sudo apt-get upgrade”. I would say do that and try again.

      • Tejas Melkote

        Hi Joseph. Thank you for the reply. I will try that and let you know. 🙂

  • Raimundo García Magadán

    Renew [ssl] certificates:

    1) SSH into your RPi
    2) Type: wget https://certs.godaddy.com/repository/valicert_class2_root.crt
    3) Type: sudo cp valicert_class2_root.crt /usr/local/share/ca-certificates/
    4) Type sudo update-ca-certificates (You should see a new ca-cert added to the system. You can verify by looking for the new certification in /etc/ssl/certs/ called valicert_class2_root.pem)
    5) Type: reboot

  • Jay Danziger

    Hello everyone, so appreciative for all the work that has been done. I am using Raspberry PI 3 and Retropie and running xarcade2jstick and it works great on MAME Advance. However I have not been able to get Super Mario 3 on Nintendo (not talking SNES) to work. Despite setting up both gamepads and they work on MAME, when I go into this game the bottom says Xarcade Gamepad Device 1 not configured…and the same for Device 2. I am at a complete loss at this point in time. I have tried so much. I know this program uses /dev/input/js* and I read that this uses the linuxraw driver (udev is retroarch default). I tried changing this to no avail. I also tried sdl and others….nothing gets me to the point that says device configured. Finally I even created files using rgui for autoconf and this seems to be ignored as well. Any suggestions would be so appreciate…this has been 2 weeks for me now on this issue!

  • Vinicius Silva da Cruz

    OMG ty…

  • WhoMe?

    Is there a way to put a “sync” option into the code for 360 controllers? When using a diy receiver from a dead 360 there is no sync button on the receiver and that is an issue

  • Fleder

    Hello there, is this compatible with the Orange Pi PC?

  • Pingback: DIY Retro Game System Showdown: RetroPie vs. Recalbox | The New Peoples Almanac()

  • Pingback: DIY Retro Game System Showdown: RetroPie vs. Recalbox | BeautyCribTV()

  • Pingback: DIY Retro Game System Showdown: RetroPie vs. Recalbox - Lifehacker Guru()

  • Pingback: DIY Retro Game System Showdown: RetroPie vs. Recalbox « Fribliss()

  • Pingback: DIY Retro Game System Showdown: RetroPie vs. Recalbox | Caribbean Focus :)()

  • Pingback: DIY Retro Game System Showdown: RetroPie vs. Recalbox | Jamaican Moments™()

  • Pingback: DIY Retro Game System Showdown: RetroPie vs. Recalbox | Intelligent Jamaica()

  • Pingback: DIY Retro Game System Showdown: RetroPie vs. Recalbox()

  • Pingback: DIY Retro Game System Showdown: RetroPie vs. Recalbox – Factotic()

  • Pingback: DIY Retro Game System Showdown: RetroPie vs. Recalbox – Fantotic()

%d bloggers like this:
Skip to toolbar